Binary distribution of v12.0.rc1 available via CernVM FS but there are issues


I would like to provide some feedback on my experience building v12.0.rc1 for distribution via CernVM FS.

I built this candidate release on CentOS 7 and on Yosemite and the binary is now online. If you had already installed the CernVM FS client software, you can try this new version just by doing:

cd /cvmfs/
source loadLSST.bash

If you have not yet installed the client software, you can find the installation instructions at:

For Linux, the binary of v12.0.rc1 was built on CentOS 7. Unlike previous versions built and distributed in the same way, you cannot use v12.0.rc1 on Ubuntu 14.04. This is inconvenient and I’m trying to understand how to solve or at least turnaround this issue. See error messages at:

Feedback from the stack developers/packagers would be highly appreciated. So far I have been able to avoid building and distributing a separate version of the stack for each Linux distribution of interest. In other words, the Linux binary distribution built on CentOS worked on several distributions of Linux (including Scientific Linux, Ubuntu and even Mint). This is not the case with v12.0.rc1 and is inconvenient.

Is there any recommended path forward?

Just so that people aren’t wondering about the silence, the discussion on this is in the Github issue linked above.

To summarise this issue, a solution was found by specifying to the location of the Python interpreter to be used for bootstrapping the installation. We used a path which works on both CentOS and Ubuntu. The stack built this way is already available online.

Thanks to @timj, @jbosch and @mjuric for their help.

There is still a separate issue for this binary to work on Ubuntu which seems related to this conversation and the associated DM-5802 ticket.

Progress on that issue can be tracked here.

The issue mentioned above is now solved for v12.0. Although built on CentOS 7, it works also on Ubuntu 14.