Version 2.3.5 of lsst_sims available via conda install


(Scott Daniel) #1

Thanks to @jmatt, there is now a conda-installable binary for version 2.3.5 of the lsst_sims stack.

Caveats:

  • There is only a python 2 binary. There is no binary version for python 3.
  • You will need to install the new version in a new conda environment (instructions below). Do not attempt to update a previous conda-install of the lsst_sims stack.

Instructions:

Create a new conda environment in which to install lsst_sims
conda create --name sims-2.3.5 python
Activate the new environment
source activate sims-2.3.5
Add the correct conda channel to your configuration
conda config --add channels http://conda.lsst.codes/sims/2.3.5
(you can verify the channels in your conda config by running conda info)

Install lsst_sims
conda install lsst-sims=2.3.5.sims
Note: This will result in a lot of warnings that look like
/Users/danielsf/physics/conda-for-install/miniconda2/lib/python2.7/site-packages/conda/core/link.py:471: UserWarning: Package http://conda.lsst.codes/sims/2.3.5::lsst-sims-2.3.5.sims.post2-0 uses a pre-link script. Pre-link scripts are potentially dangerous. This is because pre-link scripts have the ability to change the package contents in the package cache, and therefore modify the underlying files for already-created conda environments. Future versions of conda may deprecate and ignore pre-link scripts.
Do not be alarmed. This is due to known peculiarities in how eups interacts with conda.

Once lsst_sims has been installed, you can set it up (in the eups sense) by
source eups-setups.sh setup lsst_sims -t conda

Final caveat:

The Data Management team is developing a binary release tool based on EUPS, which will replace conda as the means of getting binary installations of LSST software tools, including the Simulations Stack. The goal is to complete this transition in July. Conda builds will be available up until this transition takes place but the timescales mean that this is likely the last Conda build.

To remain current with the development branches of sims we encourage you to install from source.


(Ashley Villar) #2

Thanks @danielsf!
When I tried to install this with anaconda today, I am getting the following error:

IOError: [Errno 2] No such file or directory: u’[my directory]/.conda/envs/.pkgs/lsst-sims-sed-library-2017.01.24-0/var/opt/eups/ups_db/sims_sed_library/2017.01.24.version’

Any ideas on what might be going on? I unfortunately don’t want to build from source because I don’t have root access

Thanks!


(Scott Daniel) #3

Hi @ashleyvillar,

What version of conda are you using? Some cursory googling indicates that something like this has been happening to people running older versions of conda. I used version 4.3.13 successfully on a Mac.

Also: are you installing on a Mac or a Linux machine?


(Ashley Villar) #4

Hi @danielsf -

I upgraded conda to 4.3.8 on a centos 6.8 system. This worked, but lead to more errors :slight_smile: I’m now getting the following error:

UnsatisfiableError: The following specifications were found to be in conflict:

  • lsst-mysqlpython -> lsst-mariadbclient ==0.10.1.11.3
  • lsst-mysqlpython -> lsst-python-eups-configs ==0.0.5
  • lsst-sims 2.3.5.sims* -> lsst-ephem ==3.7.6.0 -> lsst-python-eups-configs ==0.0.6
  • lsst-sims 2.3.5.sims* -> lsst-sims-alertsim ==2.3.5.1.sims.post1 -> lsst-daf-persistence ==0.13.0.8.post1 -> lsst-mariadbclient ==0.10.1.21.1
    Use "conda info " to see the dependencies for each package.

Do I need to upgrade/downgrade some packages individually to resolve this? Thanks!


(Scott Daniel) #5

lsst-mysqlpython is an old package. We have, I believe, dropped it from the stack in favor of lsst-python-mysqlclient. Also, the version of lsst-mariadbclient associated with 2.3.5.sims is 0.10.1.21, not 0.10.1.11.3.

Are you trying to install this stack on top of a previous conda install of lsst_sims? Did you remember to create a new environment in which to install?


(Scott Daniel) #6

Note: you will need to enter your new environment using
source activate sims-2.3.5
(or whatever you named the environment) every time you try to use this installation of the stack.