Change in naming of base_Blendedness and meas_deblender fields

Ticket DM-16070 has just been merged. This implements RFC-534: Update naming of base_Blendedness fields. The names of the “flux” fields in the base_Blendedness measurement algorithm and one in meas_deblender were causing mild headaches due to somewhat unconventional/misleading naming, so they have been changed to be more clear and in line with current conventions.

Specifically, the implementation of this RFC includes:

  • base_Blendedness_raw_instFlux --> base_Blendedness_raw
  • base_Blendedness_abs_instFlux --> base_Blendedness_abs
  • base_Blendedness_raw_instFlux_child --> base_Blendedness_raw_child_instFlux
  • base_Blendedness_raw_instFlux_parent --> base_Blendedness_raw_parent_instFlux
  • base_Blendedness_abs_instFlux_child --> base_Blendedness_abs_child_instFlux
  • base_Blendedness_abs_instFlux_parent --> base_Blendedness_abs_parent_instFlux
  • deblend_psfFlux --> deblend_psf_instFlux

Finally, the doc strings have been updated to make a clear distinction/description between “raw” and “abs”.

These fields don’t seem to be in regular use by users, but if you find yourself requiring backwards compatibility with old catalogs, see the instructions in this post for setting up aliases.

1 Like