ImportError: libicudata.so.50


(Ying-Tung Chen) #1

Hi,

I tried to install hscPipe 7.9.1 in another computer, which is installed with ubuntu 16.04.6. The installation starts from scratch with source code (not binary distribution). There is no any error message during the installation including the steps of bash newinstall.sh and eups distrib install hscPipe 7.9.1. However, I got following error message when I test with ingestImages.py --help (and other pipe_drivers top-level scripts). I found this reference related to DM-4006, which should be solved few years ago. What is the cause could be?

error message:

Traceback (most recent call last):
File “/home/ytchen/hscpipe/stack/miniconda3-4.5.12-1172c30/Linux64/pipe_tasks/7.9.1-hsc/bin/ingestImages.py”, line 2, in
from lsst.pipe.tasks.ingest import IngestTask
File “/home/ytchen/hscpipe/stack/miniconda3-4.5.12-1172c30/Linux64/pipe_tasks/7.9.1-hsc/python/lsst/pipe/tasks/ingest.py”, line 30, in
from lsst.pex.config import Config, Field, DictField, ListField, ConfigurableField
File “/home/ytchen/hscpipe/stack/miniconda3-4.5.12-1172c30/Linux64/pex_config/7.0-hsc/python/lsst/pex/config/init.py”, line 32, in
from .convert import *
File “/home/ytchen/hscpipe/stack/miniconda3-4.5.12-1172c30/Linux64/pex_config/7.0-hsc/python/lsst/pex/config/convert.py”, line 25, in
import lsst.pex.policy
File “/home/ytchen/hscpipe/stack/miniconda3-4.5.12-1172c30/Linux64/pex_policy/7.0-hsc/python/lsst/pex/policy/init.py”, line 23, in
from .policySource import *
ImportError: libicudata.so.50: cannot open shared object file: No such file or directory


(Tim Jenness) #2

Do you have a libicudata.so installed anywhere? It’s odd though since if you built from source there shouldn’t be any library inconsistencies.


(Ying-Tung Chen) #3

I use find to go through /, find nothing. No sure if this is related cause, the gcc version in this computer is 4.9.1, didn’t match the prerequisites ( at least gcc 6.1) (reference)


(Tim Jenness) #4

gcc4 is not going to work. We use C++14 features so at least gcc6.