Installing Science Pipeline for LSST@Europe conf. tuturials, issue with

Hi everyone,

I’m getting ready for the LSST@Europe2 tutorials in Belgrade next week, but am encountering a permissions problem when trying to set up the science-pipeline stack inside Conda.

Specifically, I have installed Miniconda (Python 2.7) and am working through the setup commands listed in Section 2 on page However, having run:

% conda config --add channels

—apparently successfully, I encounter an error with the subsequent command:

% conda create --name lsst python=2
Fetching package metadata …Error: HTTPError: 403 Client Error: Forbidden for url:

I’ve tried the install on both a Xubuntu and a Windows 8 machine with exactly the same result.

Any advice as to what I am doing wrong would be much appreciated!

Thanks in advance,

Could you post the.condarc from the xubuntu machine? It is really strange that it thinks it’s arch is win-64.

Sorry, the error I logged in my previous post was from the Windows 8 attempt. I simply meant that I had also tried from a Xubuntu (32-bit) installation and got the same ‘Forbidden URL …’ error.


For completeness, on Xubuntu I get:

$ conda create --name lsst python=2Fetching package metadata …Error: HTTPError: 403 Client Error: Forbidden for url:

Unfortunately, we don’t support 32-bit architectures any more. (This means my desktop doesn’t run the stack…)

Hi K-T,

Thanks. This seems to explain why I can’t install the software stack on my 32-bit Ubuntu image, though should I be able to install on my 64-bit Windows laptop?

Thanks again,

I’m afraid not; this thread discusses the closest anyone has gotten to running the stack on Windows, and even with a new embedded Linux feature in a prerelease version of Windows 10, it doesn’t quite work.

If you can create a 64-bit Ubuntu image, that should work fine (though I’d recommend 14.04 rather than the latest Ubuntu LTS release, just because we’ve had more people try that out).

Hi Jim,

Okay, thanks. I’ll see if I can get a 64-bit Ubuntu VM, though might stress the hotel Wi-Fi!

I’ll let you know how I get on,

One more note on this: the stack can require a fair amount of memory to build (we’d very much like to reduce this, but we’re not there yet), so it’d definitely be a good idea to use a binary install (either Conda or CernVM FS) if your VM is limited in that regard (obviously, that’ll be faster too).

Hi Jim (and everyone),

Thanks. I successfully deployed the pipeline software on a 64-bit Linux system and ran the tutorials.

Thanks for your help,