Issue building FFTW 3.3.3 in LSST Stack with texinfo

I’m having trouble building FFTW with texinfo installed on my system. Texinfo builds the FFTW documentation. It looks like the FFTW version in the stack is 3.3.3 (released in '12) which has a known issue with texinfo-5. Supposedly FFTW 3.3.4 (released in March '14) fixes this issue. Anyone else run into this? Should we change the default FFTW version to 3.3.4?

I’ve tried just copying a few of the .texi files from into my LSST directory but this does not seem to work. I’ve tried aliasing ‘makeinfo’ away but that is not working. Any suggestions?

Looks like upgrading to 3.3.4 would be benign. May not even require an RFC (it’s a “u” package on; just file a ticket.

Quick fix - un-install texinfo with
sudo apt-get remove texinfo

Then re-start the stack installation.

One may have to reinstall both texinfo and parts of texlive-full but the stack passes the fftw install. Lets see if the new fftw version fixes things…

This has now been fixed and 3.3.4 is the current. Hope that it solves your problem.