Issues With Tutorial 'Processing With a Repository'

For reference I’m using the w_2015_47 distribution.

I ran into a few issues while running through this tutorial

Under Create a Data Repository in the second box there’s a line I had to change from:
python DRPDEMO_BIN$ rawInput.txt retrieve.txt
python $DRPDEMO_BIN/ rawInput.txt retrieve.txt

Then, it was necessary to move rawInput.txt to $DEMO_DIR so that it will be available to put in the appropriate options. So the box under Process the Image could look like:

mv input/rawInput.txt . $DATA_DIR/ --output ./calexp_dir --configfile ./ @rawInput.txt

However, in order to get it to run on my machine I had to remove this part:

--configfile ./

Below I’ve included what the terminal tells me when I include the config file. I’ve tried delving into the files it references, but I’m not sure what I’m looking for.

DGiles-2:single Dan$ /Users/Dan/Documents/Graduate_Research/LSST/Tutorials/working_directory/single/input/runs --output ./calexp_dir --configfile ./ @rawInput.txt
: Loading config overrride file '/Users/Dan/Documents/Graduate_Research/LSST/lsst_stack/DarwinX86/obs_sdss/2015_10.0-2-g86848f1+3/config/'
: Loading config overrride file '/Users/Dan/Documents/Graduate_Research/LSST/lsst_stack/DarwinX86/obs_sdss/2015_10.0-2-g86848f1+3/config/sdss/'
Config override file './' appears to use 'root' instead of 'config'; trying with 'root'usage: input [options] error: cannot load config file './': RegistryField 'calibrate.initialMeasurement.plugins' failed validation: Unknown key 'correctfluxes' in Registry/ConfigChoiceField
For more information read the Field definition at:
  File /Users/Dan/Documents/Graduate_Research/LSST/lsst_stack/DarwinX86/pex_config/2015_10.0-1-gc006da1+1/python/lsst/pex/config/, line 179, in __init__
    ConfigChoiceField.__init__(self, doc, types, default, optional, multi)
And the Config definition at:
  File /Users/Dan/Documents/Graduate_Research/LSST/lsst_stack/DarwinX86/meas_base/2015_10.0-1-g006ece8+5/python/lsst/meas/base/, line 109, in <module>
    class SingleFrameMeasurementConfig(BaseMeasurementConfig):

Any insights into the issue?

I’m not very familiar with this particular example, so I’m not sure what the root of the problem is, but “correctfluxes” is an old algorithm that was removed several months ago, so it looks like the “” file you’re using is very much out-of-date with the stack your using (which I think is fairly recent).