"No 'input_exposures' " Error in 'updateVisitSummary' Task


I’m trying to make a coadd from a few visits. Following the LSST tutorials and Notes from the Merian Survey, I have previous steps completed including:

      - isr
      - characterizeImage
      - calibrate
      - writePreSourceTable
      - transformPreSourceTable
      - consolidatePreSourceTable
      - consolidateVisitSummary
      - isolatedStarAssociation
      - jointcal

When I continued with the next step:

    - writeRecalibratedSourceTable
    - finalizeCharacterization
    - consolidateSourceTable
    - transformSourceTable
    - updateVisitSummary

I encountered these “No ‘input_exposures’” errors like:

lsst.ctrl.mpexec.mpGraphExecutor INFO: Executed 76 quanta successfully, 0 failed and 1594 remain out of total 1670 quanta.
lsst.ctrl.mpexec.singleQuantumExecutor INFO: Preparing execution of quantum for label=updateVisitSummary dataId={instrument: 'WFST', visit: 19821, ...}.
lsst.ctrl.mpexec.singleQuantumExecutor INFO: Constructing task and executing quantum for label=updateVisitSummary dataId={instrument: 'WFST', visit: 19821, ...}.
--- Logging error ---
Traceback (most recent call last):
  File "/home/liubinyang/lsst_stack_v26_0_0/conda/envs/lsst-scipipe-7.0.1/share/eups/Linux64/ctrl_mpexec/g218a3a8f53+ca4789321c/python/lsst/ctrl/mpexec/singleQuantumExecutor.py", line 460, in runQuantum
    task.runQuantum(butlerQC, inputRefs, outputRefs)
  File "/home/liubinyang/lsst_stack_v26_0_0/conda/envs/lsst-scipipe-7.0.1/share/eups/Linux64/drp_tasks/g5c219ae924+ebe4e6942c/python/lsst/drp/tasks/update_visit_summary.py", line 591, in runQuantum
    raise InvalidQuantumError(
lsst.pipe.base._status.InvalidQuantumError: No 'input_exposures' with detector 2 for visit 19821 even though this detector is present in the input visit summary catalog. This is most likely to occur when the QuantumGraph that includes this task was incorrectly generated with an explicit or implicit (from datasets) tract constraint.

Before this run, I had a small validation test coadding only 2 visits and this step got through with no error.

So, I was wondering if this is due to some previous error in constructing the VisitSummary? Is it required to complete this updateVisitSummary task before running the following makeVisitTable, makeCcdVisitTable, makeWarp, assembleCoadd etc. ?

Thanks in advance! :pray:

PS. I have tried to exclude the visits with this error by

pipetask run \
    -b $BUTLER_REPO \
    -i DATA/jointcal4 \
    -o DATA/SourceTable5 \
    -p /home/pubdata/WFST_PSF_test/pipelines/v26/DRP_v26.yaml#step2d \
    -d "instrument='WFST' AND exposure NOT IN (19348,23323,23324,23331,16744,18980,22060,20956,19351,18566)" \
    --register-dataset-types  --clobber-outputs  -j ${cpunum}

but another visit will show up with the same error in the next run…

Hi @rbliu,

If I read your error message correctly, it seems like there are issues with a detector 2 (at least for the visit 19821). Do you get the identical errors for all the other visits you have problems?

Hi @galaxyumi331 , thanks for your reply!
Yes, I do get identical errors for other visits. And I just realized that a possible cause might be a missing tract in the previous jointcal. Since my visits are from a dithering set, so I always got errors on the same detector.
Anyway, I have tried to include the missing tracts and so far this updateVisitSummary step looks good.

Thank you @rbliu for keeping us posted! I am glad you figured out a solution.