Package pycodestyle not accessible online

Hi everyone,

I’m trying to install hscPipe8.4 via the install script (sorry if this off-topic for here, but since it shared some code under the hood I thought I’ll chance it). After some fiddling to get the initial parts installed (thank you, HSC helpdesk!) the installation essentially stalls at

[ 20/94 ] pycodestyle 2.3.1-6-g0d131b0 …

for hours with no progress.

After some more fiddling to run the actual eups distrib install command it again stalls on

eups distrib install -v -v -v --nodepend pycodestyle

http://tigress-web.princeton.edu/~HSC/hscPipe8/src/manifests/pycodestyle-2.3.1-6-g0d131b0.manifest has already been retrieved into /tmp/eups/distrib/pycodestyle_11jrypq1
Looking for mapping for python 0.0.7-3-g85c3855 Linux64
Looking for mapping for pycodestyle 2.3.1-6-g0d131b0 Linux64
Using Distrib type: eupspkg
[dl] Config parameter, EUPSPKG_TAGGED_URL, not set; skipping
Config parameter, EUPSPKG_FLAVOR_URL, not set; skipping
Trying retrieve using EUPSPKG_URL to /tmp/eups/distrib/pycodestyle_9cctqnmo
Looking on server for EUPSPKG http://tigress-web.princeton.edu/~HSC/hscPipe8/src/products/pycodestyle-2.3.1-6-g0d131b0.eupspkg

From there I tried to see if that file is the problem, which is indeed the case. When I try to download the file using wget, it makes it to 87% (or 84.56Kb) before aborting the download after timeout. Downloading via chrome seems to complete for whatever reason, again after some long at around 90% (maybe chrome just uses a longer timeout).

I’m wondering if that file somehow got corrupted on the webserver and thus effectively breaks the install script? Or is there some workaround where I can download the file locally and then install this file separately?

Any help will be greatly appreciated.

Thanks
Ralf

The pycodestyle-2.3.1-6-g0d131b0.eupspkg file seems to be fine. I’ve had some trouble retrieving it via wget:

$ wget http://tigress-web.princeton.edu/~HSC/hscPipe8/src/products/pycodestyle-2.3.1-6-g0d131b0.eupspkg
--2021-01-27 13:08:03--  http://tigress-web.princeton.edu/~HSC/hscPipe8/src/products/pycodestyle-2.3.1-6-g0d131b0.eupspkg
Resolving tigress-web.princeton.edu (tigress-web.princeton.edu)... 128.112.173.29
Connecting to tigress-web.princeton.edu (tigress-web.princeton.edu)|128.112.173.29|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 98641 (96K) [application/x-troff-man]
Saving to: ‘pycodestyle-2.3.1-6-g0d131b0.eupspkg’

pycodestyle-2.3.1-6  77%[==============>     ]  74.67K  --.-KB/s    in 0.1s    

2021-01-27 13:08:03 (590 KB/s) - Read error at byte 76457/98641 (Connection reset by peer). Retrying.

--2021-01-27 13:08:04--  (try: 2)  http://tigress-web.princeton.edu/~HSC/hscPipe8/src/products/pycodestyle-2.3.1-6-g0d131b0.eupspkg
Connecting to tigress-web.princeton.edu (tigress-web.princeton.edu)|128.112.173.29|:80... connected.
HTTP request sent, awaiting response... 206 Partial Content
Length: 98641 (96K), 22184 (22K) remaining [application/x-troff-man]
Saving to: ‘pycodestyle-2.3.1-6-g0d131b0.eupspkg’

pycodestyle-2.3.1-6 100%[+++++++++++++++====>]  96.33K  --.-KB/s    in 0.04s   

2021-01-27 13:08:04 (616 KB/s) - ‘pycodestyle-2.3.1-6-g0d131b0.eupspkg’ saved [98641/98641]

This seems to be repeatable, and probably the origin of the problems in eups (I doubt eups retries downloads like wget does). I replaced the file with itself, and it hasn’t helped. I’m not sure what the problem is.

One option would be to mirror the package repo locally, and install from there (override EUPS_PKGROOT).

Ooh, maybe try replacing http with https in the EUPS_PKGROOT envvar. When I wget https://tigress-web.princeton.edu/~HSC/hscPipe8/src/products/pycodestyle-2.3.1-6-g0d131b0.eupspkg, it works without the read error.

Thanks for looking into this.

After some grep’ping different things I found the configuration URL in the variables file, and have mirrored the 8.4 branch from tigress.princeton to a local webserver. So far seems to be running just fine, keep fingers crossed.

Still weird the file consistently stops downloading at the same byte position…

I ran into similar issue, and changing EUPS_PKGROOT in loadLSST.bash such that it reads:

export EUPS_PKGROOT=${EUPS_PKGROOT:-https://tigress-web.princeton.edu/~HSC/hscPipe8/src}

helped the install process move forward.