PhoSim ./configure errors


I recently came across PhoSim and would like to give it a try. However, when I try to install the software using ./configure before making, I get the following error:
“bash: ./configure: /bin/tcsh: bad interpreter: No such file or directory”

Not sure what’s causing the issue. I can install other packages using ./configure and make without error (such as cfitsio and fftw independently, for example). So far I’ve tried this with Linux (Mint, specifically) and Windows (via cygwin), and I get the same error.

Any insight or help on this issue would be appreciated, thanks!

(As a side note: Windows 10 apparently doesn’t like the phosim/data/aux directory; if I try to remove this directory, I get “this file/folder is no longer in this directory” errors, which are hard to get around)

Hi there,

I think the problem really is that phosim doesn’t use autoconf like most other packages that provide a configure script. The configure script shipped with phosim is really just a shell script that does some setup. I think the phosim devs can probably help you if you file a ticket here. Hope this helps.