Problem with the initial step of a source install

I’m running into a problem at the very first step of a source install. I’m running MacOS 10.9 with all the xcode extensions, FWIW.

I successfully download

bash-3.2$ curl -OL
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 12661  100 12661    0     0  45387      0 --:--:-- --:--:-- --:--:-- 45543
bash-3.2$ ls -ltr
total 32
-rw-r--r--  1 idellant  staff  12661 Oct 30 12:53

but when I run the installer:

bash-3.2$ bash

LSST Software Stack Builder

Detected git version 1.9.5 (Apple Git-50.3). OK.

In addition to Python 2.7, some LSST packages depend on recent versions of numpy,
matplotlib, and scipy. If you don't have all of these, the installation may fail.
Using the Anaconda Python distribution will ensure all these are set up.

Anaconda Python installed by this installer will be managed by LSST's EUPS
package manager, and will not replace or modify your system python.

Would you like us to install Anaconda Python distribution (if unsure, say yes)? yes

Installing EUPS (v1.5.9)...  FAILED.
See log in eupsbuild.log

eupsbuild.log shows that curl fails to build files, so tar dies.

bash-3.2$ cat eupsbuild.log
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0tar: Child died with signal 11
tar: Error is not recoverable: exiting now
100   131    0   131    0     0    467      0 --:--:-- --:--:-- --:--:--   469
  0     0    0 17254    0     0  23146      0 --:--:-- --:--:-- --:--:--  472k
curl: (23) Failed writing body (0 != 1370) line 278: cd: eups-1.5.9: No such file or directory line 286: ./configure: No such file or directory
make: *** No rule to make target `install'.  Stop.

I tried playing with, and there’s an if statement that calls either curl or wget, but I’m hesitant to change the code… Is there an easy fix?

It looks like your curl is working OK (it downloaded twice). I’m a little worried about your tar. It shouldn’t be segfaulting.

I don’t see anything in that references wget. Where is that? Besides, MacOS doesn’t usually come with wget.

My mistake–I was trying it by hand–the if/fi switch is “curl” vs. “git clone”, not wget.

Do you have 3rd party unix tools installed, e.g. via homebrew, MacPorts or fink? If so, which compiler, tar, and curl are you trying to use? If they aren’t the standard system installs I suggest disabling your 3rd party packages.

So you might try it manually to see where the problem is:

curl -LO
tar xzvf 1.5.9.tar.gz

Thanks Russell and KT–it was indeed an evil link of tar to gtar in my path. Disabling the link gets me past this step!