Problem with tutorial: "Install transmission curves"

I was following the tutorial in LSST website to install the transmission curve to the raw data, but the python code is not found.

ci_hsc DATA
$ DATA command not found

I did a search in my linux system, but is not found as well,
so I installed the package obs_subaru from github, which contains the python code, by executing

git clone

However, I still don’t understand how to make use of the file, obs_subaru, in order to install transmission curve.

I have gone through the "Installing the LSST Science Pipelines " section, and the LSST pipeline is successfully installed and tested.

Any help will be really appreciated.

To make use of any package in the LSST Pipelines, you generally need to make sure it is “set up” by EUPS. I imagine you have already done this for the regular versions of the packages that you originally installed, with line like

setup lsst_distrib -t <some-tag>

To use your custom version of obs_subaru, you’ll also need to run:

cd obs_subaru
setup -j -r .

The -j flag tells EUPS to set up “just” obs_subaru (and not its dependencies) - I’m assuming here that you had previously set up some other version of obs_subaru, and hence all of its dependencies are already setup. There are many other ways to get the same result, but this is probably the simplest one.

However, any version of the LSST Pipelines that requires the transmission curves should come with an obs_subaru version that has the script to install them, and any version does not have that script should not need them (or even be able to use them). So if you’re going through the tutorial with an older version of the pipeline (such as 14.0), you can just skip the step. If you’re using 15.0 or a recent weekly build, we should investigate why the installed version of obs_subaru doesn’t seem to have this script.

I will skip that part then. At least I know how to setup a custom version of a package now.
Thank you for the reply.

I was wondering if you could fix this problem? I’m having the same issues with that part of the tutorial.

Could you say more about what you tried to do and how it failed? The original post did not involve anything we’d consider a bug, just an explanation of how to do things and a warning about versions that are now very old, so if you have found a bug, it may be a new one.

Hey! yeah, my bad.
I realize that now :woman_facepalming: I think my problem is with the version too. Thanks for your reply!