Questions about installing v26_0_0 on CentOS 7

Hi all, I’m installing the LSST Science Pipelines v26_0_0 on a Linux CentOS 7 machine. I followed steps on Install with lsstinstall and eups distrib — LSST Science Pipelines
When I ran

./lsstinstall -T v26_0_0

I received this error:

Downloading  (5) ━━━━━━━━━━━━━━━━━━━━━━━   9.0MB git-lfs                    0.5s
Extracting   (5) ━━━━━━━━━━━━━╸━━━━━━━━━       2 libzopfli                  0.3sterminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc
/data0/shenming/lsst_stack_v26_0_0/conda/etc/profile.d/ line 250: 105697 Aborted                 (core dumped) "$MAMBA_EXE" $_CE_M $_CE_CONDA "$@"
Unable to create conda environment lsst-scipipe-7.0.1

Could anyone give me some help? Should I install another version instead? (e.g., v25_0_4?)

Are you doing the install on a memory-constrained system?

Thanks. I’m not sure about that…
Later I tried Install with and eups distrib — LSST Science Pipelines and it’s working (~15 min).
Then I tested Testing the Science Pipelines installation with a demo — LSST Science Pipelines and it’s working as well (~10 min).

@sfu – does your most recent post mean the issue fixed itself (i.e., it was perhaps a temporary or transient service outage), can we consider this topic as resolved?

Hi @MelissaGraham , yes, it’s resolved.

1 Like