RSP install at IN2P3

We are trying to deploy the Rubin Science Platform at IN2P3. We have tried on bare metal servers and more recently on openstack VMs. Up to now we have followed the instructions from @stvoutsin in, this was very useful as a it allowed us to understand many things on the RSP. We have been able to launch Firefly and to display a few images but we are now stuck with nublado. I understand that the deployment procedure is being updated now and that the instructions that we have followed are outdated.
I would like to know if we can get some guidance in order to complete the platform deployment and I would also appreciate if someone could point us to some documentation / links to help us understand the architecture of the RSP and the interactions between the various components ?

Hello Dominique,

Could you provide some details on what errors you are seeing with Nublado?

The notes you found are a bit out of date, and use older versions of the Helm charts & Docker images, so if you are using more recent Helm charts & Docker images you may run into issues, most likely related to changes to how authentication works with newer versions of the code & charts.

If you are seeing errors in Kubernetes that look like “pod has unbound PersistentVolumeClaims” it could be that you haven’t changed the storage class provisioner to “”, so that Openstack is able to create volumes. (see: lsst-sqre/charts -> fileserver/templates/storageclass.yml#L5)

You may also be seeing issues related to authentication, depending on what version you are deploying and with what configuration. For the release I used which is documented in the link you found, I setup and used a Github OAuth application, then copied the client_id & secret into the nublado-values.yaml file, and set the oauth_provider: ‘github’ in the values.yaml configuration file of the “nublado” helm chart. This enabled me to have access to Nublado for authenticated Github users.

Another possible issue could be to how you are exposing the service, i.e. public IPs, Nginx Ingress & ports within Kuberenetes. If you have some notes on what you have tried so far it may be easier to have a look and see if something stands out as an apparent cause.

Hope this helps

1 Like

Thanks a lot Stelios, this is very useful. I am going to try what you suggest. I would really like to make this working even if a new deployment system is made available.

Following the demo after the Rubin Operation Bootcamp and the instructions from @cbanek I have been able to successfully install the minikube version of the RSP on my laptop. I will use this as an example / starting point to deploy the RSP on openstack.

For anyone else who might find this useful, the agenda page for the “Rubin Operation Bootcamp” is viewable here, and includes links to video recordings of all the presentations.

@boutigny, the demo that you refer to – was it the Day 1 10:30am talk on the IDF by Wil and Hsin-Fang, or the Day 2 12:00pm talk on the Science Platform by Frossie? Or maybe both were helpful?

1 Like

Neither; I believe it was the Special Event on Friday.

1 Like

Yes, this was the topic of the Friday special event: Deploying Kubernetes services with ArgoCD (Christine Banek) Video recording