Struggling to install lsst_distrib v26_0_0 on M3 mac

Hello, I am trying to install the pipeline and am unable to get past the meas_transiNet g2ca692352a+96dd2c2ea9 installation. I downloaded eups and have tried both the “Install with lsstinstall and eups distrib” and “Install with and eups distrib” procedures but both run into the same problem. The download always hangs when I reach step 57 meas_transiNet, I let this run overnight but it makes no progress. When I cancel the download I am shown this message:

I am not sure how to get past this issue, is there a different version of the lsst_distrib I should try installing?

I tried doing a fresh install of miniconda using the and then ran ‘eups distrib install -t w_latest lsst_distrib’ and run into a new issue with sconsUtils:

Not sure what this test means or why it is failing.

Hi @pladuca , apologies for the lack of response here, I’ll try to find someone to help with this.

In the meantime, anyone else who sees this and has thoughts, please jump in.

Since meas_transiNet uses pytorch I assume something is going wrong with the pytorch that is coming with the rubin-env=7 environment on osx-arm64. Looking at my own computer rubin-env=8 (which goes with v27.0.0.rc3) gives a cpu version of pytorch but rubin-env=7 gives a gpu version of pytorch. But I don’t know where this constraint comes from. I don’t know if “try lsstinstall with v27.0.0.rc3” is an option for you (or the latest weekly).

1 Like

Can you paste the contents of that linter-ruff.log.failed file it is reporting in that sconsUtils failure?

Hi @pladuca,

I wonder if you succeeded with installing the v26 pipeline on your M3 mac. If so can you post your “how-to” in this thread and mark as a Solution? If you haven’t succeeded yet, can you share the failure reporting file, so Tim can help with?

Hello all,

Thank you so much for the responses, I am sorry I didn’t notice them sooner. I ended up figuring out a way to get the pipeline working. I tried multiple times using these instructions Install with lsstinstall and eups distrib — LSST Science Pipelines which use lsstinstall; however, I was never able to get this working. I also tried installing the weekly version and that would also fail as shown in my original posts. I then tried following these instructions Install with and eups distrib — LSST Science Pipelines using the, this had me downloading a new anaconda as part of the install process and I was able to get this working only for the main release not the weekly. I still don’t know what made the difference but I do have a working environment! Let me know if there is anything I can send that would be helpful.

We build on Macs all the time. I would like to know the errors you encountered so I can determine if they are fixed in newer versions or not. newinstall vs lsstinstall shouldn’t make any difference once you’ve started doing the build itself and are making progress so the sconsUtils and transinet failures are hard to explain without more information.

We are planning to do macOS Apple Silicon binary releases in the future.

I am not sure how to check what errors I encountered besides the screenshots I shared. I never really figured out what was happening since the install would just stall on transinet and fail with the error shown above for sconsUtils. I there any way I could get more information?

The sconsUtils error points at a linter-ruff.log.failed file that has the error message in it.

The transiNet one is harder because it’s a hang. The log seems to show that the tests finished fine so I can’t really explain why it got hung up. That’s likely going to remain a mystery.