Problem when install science pipeline package

Tags: #<Tag:0x00007fdd851ce570>

I follow the instruction on this page. when I tried to install science pipeline package by typing
eups distrib install -t v22_0_0 lsst_distrib
in terminal. It always stops when installs sconsUtils 22.0.0.
And it looks like this:
My lap: Apple M1
Thanks for help!

   [  1/79 ]  alert_packet master-gbd80f2fea6 (already installed)        done. 
   [  2/79 ]  eigen 3.3.7.lsst2-1-g398bedf (already installed)           done. 
   [  3/79 ]  fgcm lsst-dev-g14fa2066fb (already installed)              done. 
   [  4/79 ]  obs_decam_data 22.0.0 (already installed)                  done. 
   [  5/79 ]  obs_lsst_data 22.0.0 (already installed)                   done. 
   [  6/79 ]  obs_subaru_data 22.0.0 (already installed)                 done. 
   [  7/79 ]  obs_test_data 22.0.0 (already installed)                   done. 
   [  8/79 ]  proxmin lsst-dev-g79c0498783 (already installed)           done. 
  [  9/79 ]  sconsUtils 22.0.0 ... 

***** error: from /Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/build.log:
+ ./ups/eupspkg FLAVOR=DarwinX86 VERBOSE=0 fetch
+ ./ups/eupspkg FLAVOR=DarwinX86 VERBOSE=0 prep
+ setup --type=build -k -r .
++ /Users/pennyan/lsst_stack/conda/miniconda3-py38_4.9.2/envs/lsst-scipipe-0.4.3/eups/bin/eups_setup DYLD_LIBRARY_PATH= --type=build -k -r .
+ eval export 'PATH=/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/sconsUtils-22.0.0/bin:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/alert_packet/master-gbd80f2fea6/bin:/Users/pennyan/lsst_stack/conda/miniconda3-py38_4.9.2/envs/lsst-scipipe-0.4.3/eups/bin:/Users/pennyan/lsst_stack/conda/miniconda3-py38_4.9.2/envs/lsst-scipipe-0.4.3/bin:/Users/pennyan/miniforge3/condabin:/opt/homebrew/bin:/opt/homebrew/sbin:/Library/Frameworks/Python.framework/Versions/3.9/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/TeX/texbin:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/fgcm/lsst-dev-g14fa2066fb/bin;' export 'PYTHONPATH=/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/sconsUtils-22.0.0/python:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/proxmin/lsst-dev-g79c0498783/lib/python:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/alert_packet/master-gbd80f2fea6/python:/Users/pennyan/lsst_stack/conda/miniconda3-py38_4.9.2/envs/lsst-scipipe-0.4.3/eups/python:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/fgcm/lsst-dev-g14fa2066fb/lib/python;' export 'SCONSUTILS_DIR=/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/sconsUtils-22.0.0;' export 'SETUP_SCONSUTILS='\''sconsUtils' LOCAL:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/sconsUtils-22.0.0 -f DarwinX86 -Z '(none)'\'''
++ export PATH=/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/sconsUtils-22.0.0/bin:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/alert_packet/master-gbd80f2fea6/bin:/Users/pennyan/lsst_stack/conda/miniconda3-py38_4.9.2/envs/lsst-scipipe-0.4.3/eups/bin:/Users/pennyan/lsst_stack/conda/miniconda3-py38_4.9.2/envs/lsst-scipipe-0.4.3/bin:/Users/pennyan/miniforge3/condabin:/opt/homebrew/bin:/opt/homebrew/sbin:/Library/Frameworks/Python.framework/Versions/3.9/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/TeX/texbin:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/fgcm/lsst-dev-g14fa2066fb/bin
++ PATH=/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/sconsUtils-22.0.0/bin:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/alert_packet/master-gbd80f2fea6/bin:/Users/pennyan/lsst_stack/conda/miniconda3-py38_4.9.2/envs/lsst-scipipe-0.4.3/eups/bin:/Users/pennyan/lsst_stack/conda/miniconda3-py38_4.9.2/envs/lsst-scipipe-0.4.3/bin:/Users/pennyan/miniforge3/condabin:/opt/homebrew/bin:/opt/homebrew/sbin:/Library/Frameworks/Python.framework/Versions/3.9/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/TeX/texbin:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/fgcm/lsst-dev-g14fa2066fb/bin
++ export PYTHONPATH=/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/sconsUtils-22.0.0/python:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/proxmin/lsst-dev-g79c0498783/lib/python:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/alert_packet/master-gbd80f2fea6/python:/Users/pennyan/lsst_stack/conda/miniconda3-py38_4.9.2/envs/lsst-scipipe-0.4.3/eups/python:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/fgcm/lsst-dev-g14fa2066fb/lib/python
++ PYTHONPATH=/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/sconsUtils-22.0.0/python:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/proxmin/lsst-dev-g79c0498783/lib/python:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/alert_packet/master-gbd80f2fea6/python:/Users/pennyan/lsst_stack/conda/miniconda3-py38_4.9.2/envs/lsst-scipipe-0.4.3/eups/python:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/DarwinX86/fgcm/lsst-dev-g14fa2066fb/lib/python
++ export SCONSUTILS_DIR=/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/sconsUtils-22.0.0
++ SCONSUTILS_DIR=/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/sconsUtils-22.0.0
++ export 'SETUP_SCONSUTILS=sconsUtils LOCAL:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/sconsUtils-22.0.0 -f DarwinX86 -Z (none)'
++ SETUP_SCONSUTILS='sconsUtils LOCAL:/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/sconsUtils-22.0.0 -f DarwinX86 -Z (none)'
+ ./ups/eupspkg FLAVOR=DarwinX86 VERBOSE=0 config
+ ./ups/eupspkg FLAVOR=DarwinX86 VERBOSE=0 build
scons: Reading SConscript files ...
Setting OS X binary compatibility level: 10.9
EUPS integration: enabled
Unrecognised compiler: x86_64-apple-darwin13.4.0-clang
+ exit -4
eups distrib: Failed to build sconsUtils-22.0.0.eupspkg: Command:
	source "/Users/pennyan/lsst_stack/conda/miniconda3-py38_4.9.2/envs/lsst-scipipe-0.4.3/eups/bin/setups.sh"; export EUPS_PATH="/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3"; (/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/build.sh) >> /Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/build.log 2>&1 4>/Users/pennyan/lsst_stack/stack/miniconda3-py38_4.9.2-0.4.3/EupsBuildDir/DarwinX86/sconsUtils-22.0.0/build.msg 
exited with code 252

Please see Science Pipelines Release 22.0.0 Now Available - #2 by ktl. A v22.0.1 release should be out by the end of this week.