Rebuild and session2file

Tags: #<Tag:0x00007fb37d4cbcf0>

Hello everyone,

I have trouble when running “rebuild lsst_distrib”:

*** error building product sconsUtils.
*** exit code = 2
*** log is in /home/jahumada/lsstsw/build/sconsUtils/_build.log
*** last few lines:
::::: [2020-07-23T14:17:35.931782Z] ERROR: usage: pytest [options] [file_or_dir] [file_or_dir] […]
::::: [2020-07-23T14:17:35.931791Z] pytest: error: unrecognized arguments: --session2file=tests/.tests/pytest-sconsUtils.xml.out
::::: [2020-07-23T14:17:35.931801Z] inifile: None
::::: [2020-07-23T14:17:35.931809Z] rootdir: /home/jahumada/lsstsw/build/sconsUtils
::::: [2020-07-23T14:17:35.931818Z]
::::: [2020-07-23T14:17:36.045971Z] Global pytest run: failed with 4
::::: [2020-07-23T14:17:36.054038Z] mv: cannot stat ‘tests/.tests/pytest-sconsUtils.xml.out’: No such file or directory
::::: [2020-07-23T14:17:36.056733Z] scons: *** [tests/.tests/pytest-sconsUtils.xml] Error 1
::::: [2020-07-23T14:17:36.207520Z] failed
::::: [2020-07-23T14:17:36.220029Z] scons: building terminated because of errors.

It seems I’m missing session2file:

~/lsstsw$ conda search session
Loading channels: done

Name Version Build Channel

r-session 1.0.3 r36h6115d3f_0 pkgs/r
r-sessioninfo 1.1.1 r36h6115d3f_0 pkgs/r

I tried:

~/lsstsw$ conda install -c lsst-dm pytest-session2file

but there seems to be a problem with the python version:

Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
failed

UnsatisfiableError: The following specifications were found
to be incompatible with the existing python installation in your environment:

Specifications:

  • pytest-session2file -> python[version=’>=3.6,<3.7.0a0’]

Your python: python==3.7.6=h0371630_2

If python is on the left-most side of the chain, that’s the version you’ve asked for.
When python appears to the right, that indicates that the thing on the left is somehow
not available for the python version you are constrained to. Note that conda will not
change your python version to a different minor version unless you explicitly specify
that.

The following specifications were found to be incompatible with each other:

Package certifi conflicts for:
python==3.7.6=h0371630_2 -> pip -> setuptools -> certifi[version=’>=2016.09|>=2016.9.26’]
pytest-session2file -> setuptools -> certifi[version=’>=2016.09|>=2016.9.26’]
Package wheel conflicts for:
pytest-session2file -> python[version=’>=3.6,<3.7.0a0’] -> pip -> wheel
python==3.7.6=h0371630_2 -> pip -> wheel
Package setuptools conflicts for:
pytest-session2file -> pytest -> setuptools[version=’>=40.0’]
python==3.7.6=h0371630_2 -> pip -> setuptools
pytest-session2file -> setuptools
Package ca-certificates conflicts for:
python==3.7.6=h0371630_2 -> openssl[version=’>=1.1.1d,<1.1.2a’] -> ca-certificates
pytest-session2file -> python[version=’>=3.6,<3.7.0a0’] -> openssl[version=’>=1.0.2o,<1.0.3a’] -> ca-certificates
Package pip conflicts for:
python==3.7.6=h0371630_2 -> pip
pytest-session2file -> python[version=’>=3.6,<3.7.0a0’] -> pip

Any way around this issue?

Cheers,
Paulina

It seems like you didn’t activate the lsst-scipipe environment, which means you likely didn’t source envconfig or setup.sh.

Unfortunately, adding packages on top of our current environment has problems due to upstream conda-forge changes; this should be fixed in the next weekly release. But if you want to do so in the future, you should use -c conda-forge, not -c lsst-dm, which doesn’t currently have anything useful.