Sims_utils-2.3.4.sims.eupspkg build from source fails (OS X 10.10.5)

Building the latest sims_maf from source is failing on my mac laptop (OS X 10.10.5). As far as I can tell, the method for lsst_distrib worked fine (I opted to use miniconda when prompted).

However, then the step eups distrib install lsst_sims -t sims fails at step 58/88. It looks like there’s a problem closing a file, but it’s not clear to me if that’s just a symptom of some larger problem. I have pasted the error message below (I’m not sure how to format this nicely like I’m seeing in some of the other posts). In case this is just some permission issue, I did chmod -R 777 ~/.astropy on the laptop - but that did not fix the problem.

Has anyone else encountered this issue, and is there a known solution?



[ 58/88 ]  sims_utils 2.3.4.sims ... 

***** error: from /Users/clarkson/Soft/lsst/EupsBuildDir/DarwinX86/sims_utils-2.3.4.sims/build.log:
FAIL: testFileDescriptorLeaks (__main__.MemoryTestClass)
Traceback (most recent call last):
  File "/Users/clarkson/Soft/lsst/DarwinX86/utils/13.0+2/python/lsst/utils/", line 178, in testFileDescriptorLeaks"Failed to close %d file%s" % (len(diff), "s" if len(diff) != 1 else ""))
AssertionError: Failed to close 1 file

Ran 3 tests in 7.041s

FAILED (failures=1)
File open: /Users/clarkson/.astropy/config/astropy.log
The following tests failed:
1 tests failed
scons: *** [checkTestStatus] Error 1
scons: building terminated because of errors.
+ exit -4
eups distrib: Failed to build sims_utils-2.3.4.sims.eupspkg: Command:
	source /Users/clarkson/Soft/lsst/eups/bin/; export EUPS_PATH=/Users/clarkson/Soft/lsst; (/Users/clarkson/Soft/lsst/EupsBuildDir/DarwinX86/sims_utils-2.3.4.sims/ >> /Users/clarkson/Soft/lsst/EupsBuildDir/DarwinX86/sims_utils-2.3.4.sims/build.log 2>&1 4>/Users/clarkson/Soft/lsst/EupsBuildDir/DarwinX86/sims_utils-2.3.4.sims/build.msg 
exited with code 252
[felka:~/Soft/lsst] clarkson%

Try going into ~/.astropy/config/astropy.cfg and set log_to_file=False. After the build completes, you can set it to True again, if you want.

I have it on my plate to push a more permanent fix to this problem in the near future. Sorry for the inconvenience.

[I think the problem is that, as the unit tests run, astropy is writing to astropy.log. That file handle does not get closed before our unit test checking for dangling file handles gets run. In the future, we will instruct that test to ignore file handles connecting to astropy.log.]

Thanks Daniel - setting log_to_file=False in ~/.astropy/astropy.cfg (not any of the other astropy_*.cfg variants in that directory) does seem to have fixed the problem: eups distrib install lsst_sims -t sims now worked through all 88 steps without failing.